Saturday, August 23, 2014

Latest Calibre is not compatible with CentOS 6

I tied to update to the latest Calibre (2.0.0) and discovered it will not run on CentOS 6. It appear to need glibc 3.4.15 and Qt 5. CentOS 6 uses glibc 2.12 and Qt 4. That can probably be be fixed with some static linking but getting two version of glibc to work together is tricky. If, like me, you inadvertently installed it, you can download an earlier version here:

http://download.calibre-ebook.com/1.html

The following will extract the 1.48.0 version which is the next to latest:

$ sudo rm -rf /opt/calibre/* && sudo tar -xvjf calibre-1.48.0-x86_64.tar.bz2 -C /opt/calibre

You may need to make the following symbolic link.

/usr/bin/calibre -> /opt/calibre/calibre

No comments:

Post a Comment

Off topic comments will be deleted. Comments with spelling or grammar errors may be deleted unless they have hoplophobic or statist content in which case they will be highlighted and ridiculed.